期刊在线

快速论文发表热线: 010-57745461

客服中心

全国免费咨询:

QQ : 点击这里给我发消息 3077874057


电话:010-57745461


邮箱: hexinon@163.com


邮箱:hexinon@126.com

期刊库导航

行业资讯

最新论文

最热论文

计算机网络论文3000字

2017-11-22 14:25:24  字体:   打印 收藏 

摘 要:计算机网络课程教学改革探讨 摘 要:目前计算机网络课程教学中存在着教学内容与实际脱离、教学模式不适应课程特点、实验教学环节薄弱等诸方面的问题。因此,计算机网络课程教学改革应从优化教学内容、构建新型教学模式和强化实验教学等三个方面着手进行。 推

关键词:计算机网络论文3000字


  计算机网络课程教学改革探讨

  摘 要:目前计算机网络课程教学中存在着教学内容与实际脱离、教学模式不适应课程特点、实验教学环节薄弱等诸方面的问题。因此,计算机网络课程教学改革应从优化教学内容、构建新型教学模式和强化实验教学等三个方面着手进行。

  推荐期刊:《高等理科教育》

  2010年,我国教育部制定了《卓越工程师教育培养计划》,要求为各个专业培养合格的工程技术人才。我国许多高校以此为契机,转变办学理念,调整人才培养目标以及改革人才培养机制。部分高校根据实际情况建立实践基地,并与国内外学校企业合作,让学生走出校门走出国门,到对应的实际工作岗位进行实际工作能力的培养。

  网络类课程(网络应用技术、计算机组网技术、网络设计工程技术基础)是一类实践性很强的课程,要求学生既要有理论知识,又要能掌握实际工作能力,解决实际工程问题。如何在现有网络类课程中,按照卓越计划的精神,合理安排教学培养学生,打造具有特色的网络类课程是我们应该思考的问题。

  ● 国内外的相关研究

  工业革命以来,西方发达国家工程师培养主要有两大类:美国模式和以德、法为代表的欧洲模式。美国著名高等教育学家布鲁贝克认为,美国高等教育发展有两个方向:自由探索科学真理;服务国家社会发展。这两个发展思路始终指导美国高等教育的发展,而实用主义是这两种发展思路的交集[1]。

  实用主义的三大原则就是:实用即真理,有效即有用;需求导向,服务至上;事实重于假设。美国国家经济和社会政治,在实用主义的指导下,出现了丰富多彩的多元化发展格局。MIT的工程研究成果,Standford的硅谷淘金以及苹果公司iPhone、iPad产品的全球热销,生动地说明了实用主义的魅力[2]。

  与美国模式,培养集管理、金融、工程技术于一身的工程师毛胚不同,德、法模式注重工程实践动手能力的培养,也就是培养工程师成品[3]。德国的职业教育体系依次是:实科中学、职业学院、职业专科学校、高级专科学校、再到应用科技大学。应用科技大学是德国职业教育的最高层次,可以授予职业教育硕士学位。应用科技大学与传统研究型大学有同样的社会地位,选择哪种类型的大学主要取决于学生的个人自主选择,而不是学习能力的好坏[4]。

  近年来中国的高校也开始注意工程实践能力的培养,进行了一定程度的尝试。但是与西方发达国家相比,中国高等教育中的工程教育面临一些困惑:工程实践教育改革理念缺乏、工程人才培养模式单一、缺乏科学的长效运行机制[5]。

  有些国内高校在实施卓越工程师教育培养中认为:校企合作是培养学生的实际工作能力的有效载体。但是实际情况是,校企合作、实训教育中存在一定程度的困难。对企业而言,校企合作可能只是公益性行为,收益有限而风险很多,如学生在企业期间的安全问题、生产设备的消耗、学生实习对公司管理和运营的冲击。因此很多企业并不愿意进行校企合作[6]。

  有些高校把理论教学和实践教学分开,学校进行理论教学,学生在大四时,参加校外培训,进行工程实践的学习。这样造成了理论和实践的脱节。学习理论的时候由于没有实践,对原理就没有感性认识,谈不到真正理解;培训时,由于功利的影响,局限在工程的细节,也不会再学习理论。

  ● 课程改革的预期目标

  在实施《卓越工程师教育培养计划》时,我们必须处理好共性要求与特色发展两者间的关系。根据实际的师资和社会需求,充分体现每个学校的特色。为了培养计算机网络工程人员,我们根据现有教学计划,提出以下想法:①将思科的教学体系(教材、技术、实验、认证)引入我们的计算机网络类课程中。②针对计算机专业和非计算机专业的学生,分层次教学。③在现有的实验室条件下,进行实验教学改革。

  我们的目标是改变“教师上课,学生听讲”的单向的教学模式。为计算机专业和非计算机专业的学生提供不同层次的网络工程实践的训练,培养学生主动分析、解决实际工程问题,激发学生学习兴趣。更加贴近卓越工程师的培养目标,拓宽学生的就业渠道,提高学生参加工作后的收入。

  ● 教学改革的内容

  1.教学内容的改革

  思科公司(Cisco)提供网络的全套解决方案,其产品在网络市场上占有很高的市场份额。该公司的网络技术、特别是网络设备配置技术是当前网络技术的主流。如果只学习网络理论,不学习具体公司的产品,将没有构建网络的能力。

  思科认证是由该公司针对其产品的网络规划和网络支持推出了工程师资格认证。思科公司主要提供了三个认证等级,它们所代表的专业水平从低到高依次是:初级工程师(CCNA)、资深工程师(CCNP)和网络专家(CCIE)。同时,思科公司要求其在各国的代理公司必须拥有一定数量的认证工程师,以保证对用户的服务质量。通过此认证,网络技术专业人员可以在迅速扩展的网络技术领域证明自己的相应等级的技术水准。拥有CCIE认证,将意味着在全球范围内可获得丰厚的待遇和广阔的发展空间。

  面对这样的现状,教学中一方面进行理论知识的讲解,如计算机网络模型、TCP/IP的4层模型以及协议族、IP地址的规划与设计、路由和交换的原理等;另一方面采用思科的教学体系,向学生教授实际工程中的组网原理、防火墙、路由器和交换机的配置,这有助于提高学生的网络技术水平和就业竞争力。

  我们从学生实际情况出发,采用不同的教学体系。对于非计算机专业的网络应用课程,在使用现有的教材的基础上,增加一部分基础的思科CCNA的教学内容,如路由器的基本配置,配置静态路由。目标是学生能够配置局域网,实现简单网络间的互联。

  对于计算机专业的计算机组网技术等课程,就直接引入思科的认证教材,如《CCNA学习指南(中文第六版)》(电子工业出版社)。对学生进行系统的思科工程训练,鼓励学生参加CCNA、CCNP的考试,成为合格的网络工程师。

  2.实验技术的改革   由于思科的网络设备价格昂贵,一般财政资助的实验室难以配备完整的产品系列。有些CCNP和CCNA实验必须在中、高型号的设备才能进行。实验室的设备数量有限,不可能支持1~2班的学生同时进行实验。基于这些原因,使用模拟器进行实验成为一个必然的选择。现有的可以选择的模拟器如下:思科网络学院的基于Flash技术的模拟器、Routersim for CCNA and CCNP、Boson Router SImultor、Sybex CCNA Lab和Packet Tracer[7]。

  我们对上述这些模拟器进行测试,发现难以模拟真实的网络环境,不能支持中级以上规模的实验。经过反复比较,我们决定使用Dynamips模拟器。

  在实验室中,我们在电脑上安装Dynamips模拟器,加载思科设备的真实IOS,来虚拟相应型号的思科路由器和交换机。虚拟设备的配置和工作原理与真实设备一致,虚拟设备之间和真实设备之间一样交换数据,输入和输出界面完全一致,使得在虚拟设备上进行配置和在真实设备进行配置极其相似。目前已经可以模拟路由器、交换机和防火墙,设备型号覆盖低端2600,到中端3600和高端7200系列。

  我们以两个计算机专业教学班为例,一共80人,实验以1个学生为1组。预先在每台电脑上安装好模拟器,并把每个实验做成一个固定的配置文件。CCNA级别的教学需要完成实验,分别是:①路由器的基本配置;②配置静态路由;③配置动态路由协议;④配置网络控制列表;⑤配置网络地址转换;⑥实施VLAN;⑦VLAN间的路由;⑧实施STP。

  我们以上述的⑤网络地址转换为例说明实验的过程。实验中,每个学生使用1台电脑完成实验。每台电脑中模拟了3台3660路由器,分别是R1、R2、R3。网络拓扑结构是由教师事先设定,学生通过查看连接的信息来确定网络设备的连接情况。在R2上配置网络地址转换,可以用三种方式配置:静态NAT、动态NAT、PAT。

  路由器R2是企业网关,使用动态路由协议使企业内部所有网络互联。动态路由协议使用ospf,自治系统号使用0。路由器R2配置代码如下:

  interface e0

  ip address 172.16.21.2 255.255.255.0

  no shut

  ip nat inside

  ip access-group 1 in

  exit

  interface s1

  ip address 61.171.11.1 255.255.255.252

  no shut

  ip nat outside

  exit

  access-list 1 permit 172.16.0.0 0.0.255.255

  access-list 1 permit 192.168.21.0 0.0.0.255

  ip nat inside source list 1 interface s1 overload /* 定义使用PAT*/

  router ospf 0

  network 172.16.0.0 0.0.255.255 area 0

  ip route 0.0.0.0 0.0.0.0 61.171.11.2

  我们充分发挥思科公司在网络工程方面的专业水平,采用理论和网络工程实例交替进行的教学模式,通过构建新颖的网络工程教学实验体系,使学生能有兴趣学习专业课程,提高了学生的动手能力,达到培养了不同层次网络工程师的目的。

  参考文献:

  [1]布鲁贝克.高等教育哲学[M].王承绪,等.译.杭州:浙江教育出版社,1986.

  [2][5]王世斌,郄海霞,余建星,王杰,潘海生,孙克俐.高等工程教育改革的理念与实践—以麻省、伯克利、普渡、天大为例[J].高等工程教育研究,2011(11).

  [3]顾建民.培养有竞争力的工程师:德国工程教育改革透视[J].吉林教育科学:高教研究版,2001(2).

  [4][6]陈飞.技术本科卓越工程师培养的生态体系—基于德国经验的思考[J].职业技术教育,2011(13).

  [7]张钢,黄小波.思科虚拟实验平台的构建[J].实验室研究与探索,2010(8).

  计算机网络论文参考文献:http://www.qikanol.com/jisuanjiwangluo/

[版权说明]本站论文版权属于作者本人,您可以参考、阅读、鉴赏本站论文,也可以利用本站论文进行论文创作,但不得抄袭、复制!本站免费论文主要来源于用户投稿和互联网,如果涉及到侵权问题,请联系我们予以删除。


上一篇:计算机网络论文8000 下一篇:计算机网络完全论文

联系我们

投稿咨询电话:010-57745461
投稿咨询QQ:3077874057
论文投稿邮箱:hexinon@163.com
投诉建议邮箱:hexinon@126.com
在线投稿

论文发表说明

1. 如果您需要发表论文,请联系我们,客服人员会及时处理;
2. 专业编辑人员,为您的论文提供建议,使论文顺利发表;
3. 合作期刊,全国最全,与杂志社关系稳定,保证刊期。